Search found 1 match

by DjokeM
09 Jan 2020 17:42
Forum: Gameplay issues
Topic: Mods isnt compatible with game
Replies: 1
Views: 166

Mods isnt compatible with game

Hello I have problem i yesterday download ETS2 last update,today i download ProMods version 2.42.Ets version is 1.36.2.17s,i install mods successfully i do test and its success.When i try to enable mods they said to mods arent compatible with game version.Help?