ProMods 2.45 has been released. It runs on game version 1.36 and requires ALL map DLCs. It is not compatible with open beta 1.37.

Please note that due to the COVID-19 pandemic, we are sadly unable to expand our server capacity as per usual and the free download servers are likely to be overwhelmed upon release. Please be kind and patient or use the paid service for a better experience.

Search found 2 matches

by scalpe40
27 Dec 2017 18:11
Forum: Français
Topic: [Problème] Chargement infinis au premier lancement. [Ver.2.25]
Replies: 12
Views: 3149

Re: [Problème] Chargement infinis au premier lancement. [Ver.2.25]

Bonjour,
je ne suis pas très calé mais pour ma part tout c'est bien passé après avoir retiré tous les mods que j'avais hormis powerfull-truck et ça fonctionne très bien mais est ce que toutes les versions de ETS2 sont compatibles avec cette version 2.25 ? Ça vient peut être de ça, non ?
by scalpe40
27 Dec 2017 18:03
Forum: Français
Topic: Probleme avec la promods
Replies: 7
Views: 1069

Re: Probleme avec la promods

Bonjour, J'ai aussi payé et tout c'est bien passé après avoir retiré tous mes mods que j'avais, j'ai juste rajouté le mod ultra powerful ! Pour ma part je pouvais rouler mais pas aller dans les garages pour changer l'intérieur de la cabine et beaucoup de roues de remorques étaient rouge fluo . Je n'...