Search found 1 match

by baztard
13 Apr 2019 22:49
Forum: Map mods
Topic: [REL] Project Balkans 4.0 for 1.36
Replies: 2316
Views: 652740

Re: [REL] Project Balkans 3.2 for 1.34

i use realistic russian highways. but with Project Balkans 3.0 it was working. Legacy Compatibility mod is HIGHER than Project Balkans files but it crashed one more time -------- Developers of Project Balkans. Please do something. I want to play with all my mods + Project Balkans 3.2 having same pr...