ProMods 2.46 for game version 1.37 has been released. Please be kind to the download servers :)
Please note that TruckersMP (multi-player) is still on game version 1.36 / ProMods 2.45

Search found 4 matches

by chenjames
21 Jul 2018 23:47
Forum: Off-topic
Topic: [HELP WANTED] Translating the tutorial
Replies: 163
Views: 99902

Re: Translating the tutorial

I may do the chinese(zh_TW) how to do it?
by chenjames
21 Jul 2018 09:40
Forum: Questions & Feedback
Topic: I can't play with Promods 2.27 and Rusmap 1.8
Replies: 4
Views: 747

Re: I can't play with Promods 2.27 and Rusmap 1.8

thx a lot i found whats wrong, a mod not the newest verson so i can play it now ;D
by chenjames
21 Jul 2018 03:50
Forum: Questions & Feedback
Topic: I can't play with Promods 2.27 and Rusmap 1.8
Replies: 4
Views: 747

Re: I can't play with Promods 2.27 and Rusmap 1.8

no game didnt crash and the music keep playing
by chenjames
21 Jul 2018 01:14
Forum: Questions & Feedback
Topic: I can't play with Promods 2.27 and Rusmap 1.8
Replies: 4
Views: 747

I can't play with Promods 2.27 and Rusmap 1.8

So I can't play with them. Each time I open ets2 it can play, but if I play with Prosmod and Rusmap then the loading bar just stopped. I'm ok with only promods.Image