ProMods 2.45 has been released. It runs on game version 1.36 and requires ALL map DLCs. It is not compatible with open beta 1.37.

Please note that due to the COVID-19 pandemic, we are sadly unable to expand our server capacity as per usual and the free download servers are likely to be overwhelmed upon release. Please be kind and patient or use the paid service for a better experience.

Search found 6 matches

by WFP
08 Nov 2018 19:05
Forum: Non-ProMods problems
Topic: [Piracy/No support] [Merge of 3 topics] The game will not load the mods
Replies: 8
Views: 884

[Piracy/No support] The Game Is Crashed

Guys, I Have a Problem. I Installed Southern Reigon, Afromaps, Paris Rebuild, The Great Steppe And Russian Open Space, Then, The Loading Screen Is Going To Crash The Game. So, If You Wanna Fix It, The Game Will Fixed Soon. :(
by WFP
08 Nov 2018 18:33
Forum: Map mods
Topic: [REL] The Great Steppe - v 1.36 [1.36.x] [rel: 23.12.19]
Replies: 551
Views: 244826

Re: [REL] The Great Steppe - v 1.2 [1.31.x] [rel: 05.09.18]

Can You Make The Great Steppe 1.3 Version With 1.32 Compatible?
by WFP
08 Nov 2018 06:57
Forum: Non-ProMods problems
Topic: [Piracy/No support] [Merge of 3 topics] The game will not load the mods
Replies: 8
Views: 884

[Piracy/No support] [Merge of 3 topics] The game will not load the mods

I got Game Crashed. I Installed Southern Region, Then, The Loading Screen Is The Game Crashed. Help Me, Please?
by WFP
07 Nov 2018 17:29
Forum: Map mods
Topic: [REL] Southern Region Map 7.9.0 [1.35.x] + Fix for 1.36 [UPD 2019-12-15]
Replies: 2173
Views: 686567

Re: [REL] Southern Region Map 7.5.0 [1.32.x] [UPD 18.10.18]

This Part File Is Can not Open the File as 7z archive Is not Archive. Can You Fix It?