Search found 1 match

by luisferreira111
24 Nov 2019 20:33
Forum: Questions & Feedback
Topic: Problem with incompability
Replies: 1
Views: 296

Problem with incompability

Hello everyone,

i have the last version of the ETS2 v1.35.3.20s (64bit) and when i go to active ProMods 2.42 say incompatible!!

Someone can help me?