Search found 1 match

by fede_riX
14 May 2019 15:29
Forum: Questions & Feedback
Topic: ETS2 v1.34.0.41s it does not work whit PRO MODS v2.40
Replies: 5
Views: 658

ETS2 v1.34.0.41s it does not work whit PRO MODS v2.40

I have just downloaded the mod, and when I go to the mod manager on ets2 it tells me that it is incompatible