ProMods 2.46 for game version 1.37 has been released. Please be kind to the download servers :)
Please note that TruckersMP (multi-player) is still on game version 1.36 / ProMods 2.45

Search found 1 match

by SABA91
02 Oct 2019 19:25
Forum: Italiano
Topic: Domanda sulla compatibilità della mod
Replies: 13
Views: 2362

Re: Domanda sulla compatibilità della mod

salve, io ho la versione di ets2 1.35.3 e promod 2.41 non mi funziona per incompatibilità con la versione del gioco. sapete aiutarmi? grazie mille