Search found 1 match

by mardaniel23
06 Dec 2019 15:39
Forum: Español
Topic: No compatible 2
Replies: 4
Views: 524

No compatible 2

hola me pasa lo mismo que damian!! pero me dice que los mods no son compatibles con la version del juego el ETS 2 tuvo una actualizacion y de ahi no me los toma..