ProMods 2.46 for game version 1.37 has been released. Please be kind to the download servers :)
Please note that TruckersMP (multi-player) is still on game version 1.36 / ProMods 2.45

Search found 1263 matches

by Chris94_NOR
06 Apr 2014 18:26
Forum: Development updates and Q&A
Topic: [On hold] Development on version 2.x (Romania Edition)
Replies: 2414
Views: 562345

Re: Development on version 1.x (Romania edition)

I just have a question, is the beta version compatible with the Promods 1.61, and the DLC Going East with the latest version 1.9.22?
by Chris94_NOR
06 Apr 2014 15:07
Forum: Fixed bugs
Topic: [Fixed] [1.61] France, game crash
Replies: 47
Views: 15740

Re: Game crash before arriving Rennes(France) v1.61

Almighty wrote:This is a known bug and will be solved in v1.62 which will be release soon. You can wait till it, won't be long anymore, or you can use v1.60 to finish your job.
Is v1.60 compatible with the DLC Going East?
by Chris94_NOR
06 Apr 2014 02:39
Forum: Fixed bugs
Topic: [Fixed] [1.61] France, game crash
Replies: 47
Views: 15740

Game crash before arriving Rennes(France) v1.61

I have a situation. I was doing a mission, driving from Oslo in Norway to Rennes in France. When i was around 150 km from Rennes, the game crashed. I tried to start the game again, i started where the game crashed, I drove just a few kilometers and then the game crashed again. I did this 2 more time...