[Fixed] OpenGL texture problems

This is where fixed bugs are moved into
NiceguyChris89
Posts: 6
Joined: 08 Feb 2015 22:21
Donation rank:

25 Mar 2015 09:46

Just to add my two cents here... Not sure how to resolve this as a Mac user, but I've searched and searched but can't seem to find anything of relevance.

I have the issue with blocky text in the job market. Everything else seems to be ok though! I had ProMods 1.8 installed before, but didn't get a chance to use it before the update to 1.9. I've just tested the old version and I have the same issue.

ETS2 Version 1.16.3.1s (Steam)
ProMods Version 1.9
Mac OS X 10.10.2
Macbook Pro (Retina, 13-inch, Late 2012)
2.5GHz Intel Core i5
8GB 1600 MHz DDR3
Intel HD Graphics 4000

Issue persists without any other mods installed in profile.

Troubleshooting Completed:

> Removed Mods > UNSOLVED
> Quit & Restarted - UNSOLVED
> New Profile - UNSOLVED
> Reinstall - SOLVED.

It seems to be working for now... Although last time I took one job, and it did it halfway through. If it helps anyone, the issue first occurred when I was taking a job from Dover to Orleans. The map suddenly changed somewhere on the highway (before the turn off for orleans) from the direction of Paris (Southbound).

I'll be happy to upload any files if anyone wanted to take a closer look, but I'll keep everyone posted.

Chris

*EDIT*

Issues Persist after completing two jobs. Any Suggestions?...

LA-MJ
Posts: 776
Joined: 20 Dec 2013 16:07
Donation rank:

26 Mar 2015 07:12

Yes we know all about it. That's why this topic is here.

And if you had done a bit of research on it you'd know there are no suggestions so far...

rwowen218
Posts: 14
Joined: 06 Apr 2014 21:12
Donation rank:
Location: Toledo, OH

30 Mar 2015 20:30

I just wanted to thank you for your work on this issue. I have multiple profiles in the game to also run MsHeavyAlex and TSM maps. This is a problem in each of those maps as well. I find TSM to be the worst and is nearly unplayable. Hopefully a solution can be found soon.

NiceguyChris89
Posts: 6
Joined: 08 Feb 2015 22:21
Donation rank:

01 Apr 2015 10:20

Sorry LA-MJ, I was trying to see if there was anything I could do to help!

Anyway, I've been doing a little more playing around and I have found a workaround (of sorts) that has certainly made the game more playable with Open GL, especially as a Mac user, I have no choice with this.

I realised just this morning that I had ETS2 on a PC as a virtual machine on an external hard drive (prior to using wine/steam)...So I copied the Profile Folder from Windows into the Application Support Folder for ETS2 on my Mac.

This profile had around 60 Hours of Gameplay and most skills maxed out. One Garage & No Mods installed. This was a CLEAN profile, having never really used or been aware of mods until recently.

Having played around with this profile now for around an hour, I have had NO issues with Blocky Text, or the Map randomly changing colour. There are very infrequent issues with company logos (Ikea) and number plates on AI cars are black.

Installing other mods, such as the Scania Mod Pack, or Skins, does then cause issues with textures on the truck and some other random things, but the base game (with ProMods) still gives you plenty of additional gameplay.

Not sure why this has worked this way... Obviously there is still an issue with Open GL, but it'd be interesting to see if this works for anyone else?

Thoughts?

Chris

*In Summary
- Create Profile in ETS2 On Windows (With NO Mods)
- Copy Profile to Offending Machine
- Open Profile with ProMods & JazzyCat Pack
- Save. Done.

NiceguyChris89
Posts: 6
Joined: 08 Feb 2015 22:21
Donation rank:

01 Apr 2015 10:28

*UPDATE
- Ok, the Map just broke near Linkoping. But no Blocky Text yet... which was my biggest issue.
*UPDATE 2
- Map is Intermittent, but nowhere near as bad as it was. No Blocky Text yet. Everything else ok for now! :D

LA-MJ
Posts: 776
Joined: 20 Dec 2013 16:07
Donation rank:

01 Apr 2015 12:54

well that is just weird

I am not sure I am ready to give up 90%+ exploration yet :P

User avatar
DubLuV
Posts: 126
Joined: 03 Feb 2015 21:47
Location: Romania
Contact:

09 May 2015 13:15

Where i should post these images, i dont know... but that flower scared me.

http://i.imgur.com/BxdbhXn.jpg
http://i.imgur.com/9DR4f5i.jpg

User avatar
leillo1975
Posts: 87
Joined: 15 Dec 2014 18:33
Donation rank:
Contact:

19 May 2015 15:41

I'm happy to see that this problems (OpenGL-Linux) are been analized ;)

luka.petrovic.142
Posts: 8
Joined: 02 Nov 2014 15:36
Donation rank:
Location: Salzburg, Austria
Contact:

30 Jun 2015 10:32

Please Check Linz Linz - Salzburg i must drive Linz Praha Salzburg please fix the problem

edwinv
Posts: 22
Joined: 28 Dec 2013 11:30

16 Jul 2015 20:41

I did another round of TOBJ analysis using a problematic truck mod and wrote a little tool to fix the files. So far it seems to have fixed the font issues on both the truck mod and the MHA map. Next I'll add rusmap to the test because it used to massacre everything.

How is the current promods with regard to this issue? Since most problems occurred in the removed scandinavia parts.



Locked
  • Information
  • Who is online

    Users browsing this forum: No registered users and 5 guests