ProMods 2.46 for game version 1.37 has been released. Please be kind to the download servers :)
Please note that TruckersMP (multi-player) is still on game version 1.36 / ProMods 2.45

ProMods non funziona 2

Italian
Post Reply
Daniele_14
Posts: 1
Joined: 22 May 2016 13:16

04 Feb 2020 11:18

ciao, ho ETS2 comprato ovviamente da Steam quale versione di gioco bisogna scegliere perché il problema è che l'ultima ProMods v.243, non mi funziona, e mi dice che la mod è incompatibile per questa versione, gentilmente help me
Last edited by bmwGTR on 04 Feb 2020 12:26, edited 1 time in total.
Reason: splitted into a new topic - do NOT bump old topics

User avatar
remug
Posts: 31
Joined: 11 Mar 2017 10:29

04 Feb 2020 22:24

Hai tutti DLC obligatori? => This version requires the East, North, France, Italy & Baltic DLCs to be installed

ingsca
Posts: 1
Joined: 05 Apr 2020 16:49

05 Apr 2020 16:57

MI potreste scrivere i titoli esatti delle DLC necessarie?

User avatar
remug
Posts: 31
Joined: 11 Mar 2017 10:29

05 Apr 2020 23:40

i DLC nesessari trovi qui =>Compatibility

al momento sono East, North, France, Italy & Baltic DLC



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests