ETS 2 Promods 1.35

Installation problems or game crashes? Post them here.
Forum rules
ALWAYS FOLLOW OUR SELF-HELP GUIDE FIRST.

If you report a game crash ALWAYS post your game.log.txt in between CODE tags, or if it too large post it on pastebin.com and share the link.
matthewn20
Posts: 3
Joined: 06 Apr 2019 21:16

06 Jun 2019 05:17

Hello,

Is ProMods 2.40 compatible with ETS 2 version 1.35? I notice that I have issues saving my game onto the steam cloud when I opted for the 1.34 beta version to prevent it from updating to version 1.35 since it says that the World of Trucks connection failed. Is that part of the Steam Cloud?

User avatar
ScuL
Founder
Posts: 7911
Joined: 31 Jul 2013 23:51
Location: Auckland, New Zealand

06 Jun 2019 06:01

WoT servers are currently undergoing maintenance. ProMods 2.40 is only compatible with 1.34
I am Image Dutch living in Image New Zealand and I speak Image EN Image DE Image SE Image FR
Image

User avatar
De_Ruyter
Posts: 145
Joined: 25 Jan 2019 21:42
Location: Friesland (grr, No Frisian flag!)

06 Jun 2019 10:46

The ProMods team made rather clear way before 1.35 was even released that it wouldn't work yet. They also send out a tweet after the 1.35 release stating the same.

Just have patience, it will come but the team need time to get it working properly. Trust in the ProMods team, give them time :)

https://twitter.com/ProModsETS2
Just a trucker here, nothing to be seen. Please more along!
Image

User avatar
CptCaribbean
Posts: 2320
Joined: 24 Jul 2016 16:32
Location: Sant Andreu, Barcelona
Contact:

06 Jun 2019 11:28

In the meantime we recommend you to downgrade your ETS2 version and keep enjoying ProMods in 2.40. For doing so, you will have to go to your Steam client → LIBRARY → right click on Euro Truck Simulator 2 → Properties → Betas tab → select the version you want (in this case, 1.34).
Junior Beta-Tester since 2.26

Senior Beta-Tester since 2.30

Translator of Spanish, Catalan, Euskera and Galician.

Bluscream
Posts: 36
Joined: 30 May 2016 20:43
Donation rank:

06 Jun 2019 14:57

| [SCS Blog] Euro Truck Simulator 2 Update 1.35

https://forum.truckersmp.com/index.php? ... pdate-135/
TruckersMP Forum
[SCS Blog] Euro Truck Simulator 2 Update 1.35
Were happy to announce that after spending some time in internal testing, Experimental Beta and Public Beta, the Euro Truck Simulator 2 Update 1.35 is now ready for all trucking enthusiasts! As we have said before, this update is really huge so wed like to thank all those who...



Botdottir
BOT
Yesterday at 18:35
@Subscriber
TruckersMP Announcement

Hello Truckers,

We are aware of the current 1.35 update to ETS2 and are working on getting the multiplayer mod supported for the latest version as soon as possible.

Steam beta settings:
ETS: temporary_1_34 - 1.34.x for unsupported mods
ATS: None, opt out of beta

You can find a guide on how to downgrade your game to still be able to play the mod here:

https://forum.truckersmp.com/index.php? ... ersion-134
TruckersMP Forum
How to downgrade ETS2/ATS to supported version [1.34]
Introduction When there is a new ETS2 or ATS patch released by SCS, the TruckersMP client wont support it immediately in most cases. You must wait few days before we fully support the new update. Does it mean you cant play multiplayer during this time? No! You can, but you wi...
Image

bxnjamin97
Posts: 1
Joined: 23 Apr 2019 14:12
Donation rank:

07 Jun 2019 17:24

When I tried to load the game with the newest update all of my mod files where labelled as incompatible , is there any way to get them working?

User avatar
bmwGTR
Moderator
Posts: 2271
Joined: 10 Jul 2016 11:52
Location: Riegersburg resp. Graz

07 Jun 2019 17:28

Hi,

ProMods 2.40 is not compatible with 1.35, you have to go back to version 1.34.

Best regards,
bmwGTR
ETS2: ProMods + RusMap + Great Steppe + Southern Region + Paris Rebuild
ATS: Coast to Coast + US Expansion + CanaDream + PazzMod


ProMods Moderator since April 2018

Image

Lars09NL
Posts: 1
Joined: 01 Aug 2018 19:48

14 Jun 2019 14:45

Im using ets2 1.34 and still says its incompatible for my version with promods 2.40, i downloaded promods yesterday

User avatar
Volleybal4life
Moderator
Posts: 6800
Joined: 01 Jun 2014 15:49
Donation rank:
Location: Gouda, South Holland, The Netherlands
Contact:

14 Jun 2019 14:53

Press on the 'i' and the game will tell you what the issue is.
Spamming the forum since June 2014



Image
Some say, I'm addicted to ETS2. But then I say. No, it's ProMods, it's a way of life.
No. 3 forum spammer!

You want a game map?
You get a game map! (ETS2 (WIP))
You get a game map! (ATS (WIP))

Ruslebussen
Posts: 1
Joined: 13 Feb 2015 14:27
Donation rank:

14 Jun 2019 17:16

bxnjamin97 wrote:
07 Jun 2019 17:24
When I tried to load the game with the newest update all of my mod files where labelled as incompatible , is there any way to get them working?
All mods have a manifest, file in it. you need a program called notepad++ to edit them.
Use 7-zip or winrar to open the mod, drag the manifest out to desktop, open it with notepad++ find where it says compatible version, and 1.34X or lower and replace it with 1.35X save after edited then move the manifest file on desktop back into rar file and owerwrite. and it will work. but it does not work on Pro Mods



Post Reply
  • Information