Promods Problem

Installation problems or game crashes? Post them here.
Forum rules
ALWAYS FOLLOW OUR SELF-HELP GUIDE FIRST.

If you report a game crash ALWAYS post your game.log.txt in between CODE tags, or if it too large post it on pastebin.com and share the link.
Post Reply
Akepouchen81
Posts: 5
Joined: 08 Jun 2019 21:53
Donation rank:

12 Jun 2019 21:29

Hi I have Ets2 variation 1.35.1.1 and all map DLC
Charged home with new Promods 240. But when I start and add all, it says that they are NOT Compatible !!! Why? What am I doing wrong?

User avatar
Davyddin
Moderator
Posts: 1637
Joined: 22 Jun 2017 22:00
Donation rank:
Location: Helsingfors, Nyland, Finland
Contact:

12 Jun 2019 21:36

ProMods version 2.40 was released for and is compatible with ETS2 version 1.34.x; it is not compatible with ETS2 version 1.35.x. The team is working on a new version compatible with 1.35.x, of course, but it has not been released quite yet. In order to continue playing ProMods 2.40, you have to downgrade your game to 1.34 in Steam.
ProMods moderator, translator, and tester. ATS and ETS2 player and modder. Author e.g. of the Profile Jumpstart mods. Fennoswede from the Finnish archipelago.



Post Reply
  • Information