Page 1 of 1

CTD during map load

Posted: 14 Sep 2019 18:01
by jmiovine
Hi guys,

So, back story: I had to system restore my PC recently, my save profiles etc and mods were still there despite having to reinstall ETS2 from steam. Before I do a complete reinstall of Promods+Rusmaps+Steppe+Southern+Middle East...I want to see if there is something else I can fix causing this CTD.

Every time I'm in game and I go to the ESC main screen, maintanance shop, or any job function screen taking me out of game play, it immediately crashes to desktop.

If it helps too, it also does this on TruckersMP on the default map as well, exact same issue, so that's why I'm hesitant to beleive a reinstall of Promods will fix this issue.

I appreciate any help. Thanks.


Re: CTD during map load

Posted: 14 Sep 2019 20:36
by fropmeister

Code: Select all

00:06:47.867 : <ERROR> [dx11] meta_copy: failed to create SRV (0x887a0005)
00:06:47.867 : <ERROR> [dx11] Failed to create texture (/material/ui/link/trailer_config.tobj) (0x887a0005)
You appear to have one or more mods that don't support DirectX 11. Presumably a trailer mod.

PM's various mods do suport DX11, so you can try disabling the various other mods you have and re-enabling them one by one until you find the culprit. Or, you can run with DX9 instead.

Re: CTD during map load

Posted: 14 Sep 2019 20:42
by jmiovine
Hmm... interesting. Just curious why it also does this when opening a job screen in TruckersMp as well though...

I'll try it in DX9 and report back. Thanks

Re: CTD during map load

Posted: 14 Sep 2019 20:58
by Trucker2223
This error is actually more Graphics Driver relevant, so make sure you're graphics Driver is working properly, maybe try an older Version, since someone else had a similiar problem(but same error) and an older GPU driver fixed the problem.

Re: CTD during map load

Posted: 15 Sep 2019 02:37
by jmiovine
I ran CMD - scannow function, restarted the computer, ran it in DirectX 9 64 bit offline and ran perfectly. Back to normal offline at least.

I'm going to try MP to see if that fixed it as well. Will report back. Thanks again guys

Added in 1 hour 11 minutes 20 seconds:
MP works too.

That scannow in cmd prompt did the trick as well as running it in DirectX 9 as a previous commentor here suggested. The scannow trick said if you run it offline (even with ProMods and Rusmaps) in the DirectX 9 64 bit for a short drive, it'll fix any CTD's associated with the truckersmp

You guys are the best. Solved. Thanks!