[Fixed] [#20659] [2.41] Finland, License plates replaced by a black square

This is where fixed bugs are moved into
Locked
ErmineLogisticsOy
Posts: 5
Joined: 23 Jan 2016 11:16

08 Aug 2019 14:16

Hi,

I've just recently got more into ETS 2 and ProMods and been enjoying it a lot. However, I have an issue that I cannot fix by myself.

My register plates are missing. My HQ is located in Helsinki, with five of my trucks. None of them have license plates. Three of my trucks are in the Netherlands, they do indeed have register plates. While driving in Russia with RusMap, the plates look a lot like this: https://www.promods.net/viewtopic.php?f=20&t=29800

My own plates and Finnish NPC plates look like this:
Screenshot 2019-08-08 at 15.41.48.png
Screenshot 2019-08-08 at 15.41.48.png (26.84 KiB) Viewed 479 times
Screenshot 2019-08-08 at 16.04.49.png
Screenshot 2019-08-08 at 16.04.49.png (38.02 KiB) Viewed 479 times
Screenshot 2019-08-08 at 16.05.07.png
Screenshot 2019-08-08 at 16.05.07.png (46.5 KiB) Viewed 479 times
I tried disabling all of my mods – everything fine and dandy. Enabled ProMods 2.41 only – this ^ happens. I'm playing on a MacBook Pro, perhaps there is something wrong w/ my graphic drivers or something?

A few of the ProMods countries look a bit funny as well, but I'm not really sure which. I guess Greece had a problem. Belarusian (RusMap) and Israeli (ProMods Middle East add-on) plates are fine it seems. I'm sorry I'm a bit of a n00b here, but I hope this makes sense. I'd really like to see my plates once again. I miss 'em. :(
Last edited by Trucker2223 on 21 Aug 2019 04:17, edited 2 times in total.
Reason: Fixed
Image

User avatar
Josh0
Posts: 1488
Joined: 20 Dec 2015 02:10

08 Aug 2019 15:38

@ErmineLogisticsOy, I confirm the black license plates problem in Finland. It appears to be a problem with only OpenGL rendering; using DirectX rendering the Finnish license plates appear correctly. Since you are using a Mac your only option is to use OpenGL (thanks for mentioning you were using a Mac). I have reported this issue in our bug tracking system, bug #20659. Thank you for your report.
ErmineLogisticsOy wrote:
08 Aug 2019 14:16
A few of the ProMods countries look a bit funny as well, but I'm not really sure which. I guess Greece had a problem.
What problem(s) (specifically) do you notice with Greek license plates?

ErmineLogisticsOy
Posts: 5
Joined: 23 Jan 2016 11:16

08 Aug 2019 18:09

Josh0 wrote:
08 Aug 2019 15:38
What problem(s) (specifically) do you notice with Greek license plates?
Background of the plate was AOK, characters were black boxes, iirc. Could be it was North Macedonian or Serbian tho, since I drove all the way through Balkans and didn't pay that much attention. I'll have time for gaming later today so I can verify then, tomorrow at least.
Image

ErmineLogisticsOy
Posts: 5
Joined: 23 Jan 2016 11:16

13 Aug 2019 09:00

Took a bit longer than I expected, but here are a few pics of the plates. Greek plates were okay after all.
20190812195752_1.jpg
20190812195752_1.jpg (253.44 KiB) Viewed 363 times
Serbian and Macedonian plates look like this.
20190812213554_1.jpg
20190812213554_1.jpg (229.03 KiB) Viewed 363 times
Greek plates are a bit weird but it is what it is I guess.
Image

User avatar
Josh0
Posts: 1488
Joined: 20 Dec 2015 02:10

13 Aug 2019 13:42

The Greek license plates have some letter-spacing issues, especially with the letter "i". This is a known problem and has already been fixed in WIP.

I will investigate the Serbian and Macedonian license plates.

ErmineLogisticsOy
Posts: 5
Joined: 23 Jan 2016 11:16

14 Aug 2019 17:55

Irish, Croatian and Slovenian plates appear to have the same problem as Serbian and Macedonian.
Image

User avatar
Josh0
Posts: 1488
Joined: 20 Dec 2015 02:10

14 Aug 2019 23:37

I confirm that Serbian, North Macedonian, Irish, Croatian, and Slovenian license plates have black boxes for the text when using OpenGL only. The Irish font has already been replaced in WIP (confirmed working in OpenGL). I will add the others to my list of fonts to fix. Thank you for your report.

ErmineLogisticsOy
Posts: 5
Joined: 23 Jan 2016 11:16

15 Aug 2019 09:33

Josh0 wrote:
14 Aug 2019 23:37
Thank you for your report.
No u :D

Thank you for your response and help. :)
Image

User avatar
Josh0
Posts: 1488
Joined: 20 Dec 2015 02:10

21 Aug 2019 01:51

The original issue (bug #20659), the all-black license plates in Finland, has been fixed in WIP.

I checked the license plates of all countries in the ProMods map, the following had the "block characters" problem only in OpenGL mode: Croatia, Faroe Islands, Iceland, Ireland, Liechtenstein, North Macedonia, Serbia, Slovenia, and Spain. All have now been fixed in WIP.

The fixes should appear in the next release of ProMods.



Locked
  • Information
  • Who is online

    Users browsing this forum: Google [Bot] and 1 guest