Page 1 of 1

[Resolved] Big problem with Editor ETS2

Posted: 28 Jul 2019 08:58
by Miritellane
Problem with ETS2

Due to the impossibility of opening the map that I build with the ETS2 editor after switching to the 1.35,
and after having tested all kinds of manips, including re-installation of the 1.34….
I can NOT open my file, it crashes directly...
I can play on the map in 1.34, but the editor crashes by opening it in 1.34…!

In 1.35, it crashes directly...

After doing a clean install of ETS2 (delete by Steam and delete on disk),
I re-installed a new version of ETS2.
I took the files out of the “Documents” folder so I could start with a brand new one.
After launching ETS2 when empty, I returned to the "Documents" folder,
and I copied my own mods and profiles and Steam…

If I run ETS2 and player mode, I find my mods and profiles, and I can drive…

After modifying the config.cfg file and setting the values 1 to "developer" and "console",

I open ETS2 then the editor, then “Edit”… and then ETS2 crashes
If I remove ALL mods from the mod folder, the editor opens…. but….
it does not recognize my map file (nor the old saved versions)

Once the editor is open, I start a new map (testroute), then I save…
I check on the explorer, all files are saved in the "Base" folder…

I am leaving ETS2… then reopen it a few moments later, I launch the editor to open the file I just created (edit testroute), the editor tells me that it does not exist….!


If I go to the File/Open menu of the editor, the "Base" window that appears is empty,


while I can see my files on the explorer…
In fact, he doesn’t recognize the file he just created!!!


I don’t have any more ideas, and I’ve worked for weeks on my map for nothing…. I’m disgusted….
If someone has ideas, I am a taker…

Thank you in advance

Problème avec ETS2

Suite à l’impossibilité d’ouvrir la map que je construit avec l’éditeur ETS2 après le passage à la 1.35, et après avoir testé toutes sortes de manips, dont ré-install de la 1.34…. je ne peux PAS ouvrir mon fichier, il plante direct...
je peux jouer sur la map en 1.34, mais l'éditeur plante en l'ouvrant en 1.34…!

En 1.35, ça plante direct...

Après avoir fait une clean install de ETS2 (supprimer par Steam et supprimer sur disque),
j’ai ré-installer une version « neuve » de ETS2.
J’ai retiré les fichiers du dossier « Documents », de façon à repartir avec un tout neuf.
Après avoir lancé ETS2 une fois à vide, je suis retourné dans le dossier « Documents »,
et j’y ai copié mes mods et profiles perso et Steam…

Si je lance ETS2 et mode joueur, je trouve bien mes mods et profils, et je peux conduire…

Après avoir modifié le fichier config.cfg et avoir mis les valeurs 1 à « developer » et « console »,

J’ouvre ETS2 puis l’éditeur, puis « Edit »… et là, ETS2 plante
Si j’enlève TOUS les mods du dossier mod, l’éditeur s’ouvre…. mais….
il ne reconnait pas mon fichier map (ni les anciennes versions sauvegardées)

Une fois l’éditeur ouvert, je démarre une nouvelle map (testroute), puis je sauve…
je vérifie sur l’explorateur, tous les fichiers sont bien sauvegardés dans le dossier « Base »…


Je quitte ETS2… puis le ré-ouvre quelques instants après, je lance l’éditeur pour ouvrir le fichier que je viens de créer (edit testroute), l’éditeur me répond qu’il n’existe pas….!


Si je vais dans le menu Fichier/Ouvrir de l’éditeur, la fenêtre « Base » qui apparait est vide,


alors que je vois bien mes fichiers sur l’explorateur…
En fait, il ne reconnait pas le fichier qu’il vient de créer… !!!


Je n’ai plus d’idées, et j’ai bossé des semaines sur ma map pour rien…. je suis écœuré….
Si quelqu’un des idées, je suis preneur…

Merci d’avance

Re: Big problem with Editor ETS2

Posted: 29 Jul 2019 12:20
by arayas
First, rename "base" without capital letter and make sure you set the proper permissions for it.
Second, in mod folder make sure you have just your files, no other mods including Steam subscriptions.
Third, go to mydocuments/ets2 and delete "editor" folder, it will reset the editor.

Re: Big problem with Editor ETS2

Posted: 29 Jul 2019 13:19
by Miritellane
Thank you for your answer, but all this has already been done,
which is why I re-made a clean install of all the ETS2 files...
and nothing has changed...

Re: Big problem with Editor ETS2

Posted: 29 Jul 2019 15:15
by arayas
Stupid question, but did you copied from base also the .mdb file in your mod?

Re: Big problem with Editor ETS2

Posted: 29 Jul 2019 15:50
by Miritellane
Not stupid, bur yes, I have copied mdb....

At the moment, I just tested ATS, which I never used in editor.... and....
by opening the editor, it crashes all the same as ETS2... (yes, I modified console and developer..)...

I have the impression that it is Windows 10 the maintainer.... I will be in for a re-installation... GGGrrrrrrr

Re: Big problem with Editor ETS2

Posted: 01 Aug 2019 11:50
by Miritellane
Ooohhh... then after a complete formatting of my hard drive,
reinstallation of Windows X clean and complete, then reinstallation of Steam ETS and ATS,
I start all this, I sort out a few details and...
I get my map. ouf.... :D

thanks Windows for these problems... :cry:

Come on, let’s go...

Re: Big problem with Editor ETS2

Posted: 06 Aug 2019 08:43
by Miritellane
My problem was solved last night by a Soft SCS Driller (
who opened my map, and noticed the mistakes I had made...
eh yes, I am a beginner in mapping, so I did not understand all the explanations
of some tutos...
So this guy (very 31trucker-thanks to him) explained to me what my mistakes were,
and how to modify my files to fix all this...
After a good time taking back my files,...
Yesss... it works...

Re: [Resolved] Big problem with Editor ETS2

Posted: 08 Aug 2019 17:55
by Davyddin
Moved from map mods section to academy section.