A trailer texture mod I made for myself is not showing up in the mod manager

Modding school: Learn it from the masters
Post Reply
SimplyTadpole
Posts: 22
Joined: 03 Apr 2020 17:48

20 Apr 2020 20:36

Hi. I've been spending the last couple of days creating my own personal trailer livery to legitimize my player character's truck shipments organization instead of driving around with blank trailers, while following this tutorial. (The main difference is that I utilized paint.net instead of the numerous, often redundant programs that user utilized.) In addition to that, I also made a personal edit of the 50k addons mod so that the lightbox featured in said mod uses a texture that matches the aforementioned trailer texture, as I think it would look nicer than making a texture for the truck itself. (Not to mention easier, since I'd only have to edit one small texture instead of several.)

Unfortunately, I ran into a problem with both of these edits. My truck livery mod doesn't appear in ETS 2's mod manager at all, whereas my 50k addons edit makes the game display a red "incompatible or removed mod" exclamation mark on the enabled mod list while hiding it from the list of mods I have installed (not even showing it in the list of incompatible mods - it flat out doesn't appear at all), even though literally all I did was edit a single texture file.

I'm not sure what I did wrong, and searching the problem online gave me no results that matched with my situation - although there are people who also dealt with mods not appearing in the mod manager, none of them were creators of the mod themselves and were simply having installation troubles (like the Steam Workshop not working, or manually installing mods in the wrong location), which means that I'm the sole, single person dealing with this problem as far as I know. I tried asking for help on the ProMods and TruckSim discord servers, but I received very little responses, and the few that I did get were also confused about why this isn't working.

Does anyone have any experience with problems like this, and understand how to solve it?

EDIT: I found out what the problem was; for whatever reason, the .scs files I packaged myself were being packaged improperly, leading the game to be unable to recognize them. My solution was to take a pre-existing .scs file, and gut it of its contents to then replace with my own content. That made it work, surprisingly enough.



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests