ProMods 2.45 has been released. It runs on game version 1.36 and requires ALL map DLCs. It is not compatible with open beta 1.37.

Please note that due to the COVID-19 pandemic, we are sadly unable to expand our server capacity as per usual and the free download servers are likely to be overwhelmed upon release. Please be kind and patient or use the paid service for a better experience.

Help me

Other mods that don't fit in any other category
User avatar
paulo4
Posts: 45
Joined: 04 Apr 2016 17:02
Location: France

10 Nov 2016 17:51

Hello I am looking for someone who could explain how converting a version mod. For example, a mod version 1.24 transform it into version 1.25.
Thank you in advance. ;)
Image

User avatar
ETS2-User
Developer
Posts: 2933
Joined: 06 Aug 2014 22:34
Location: Oberösterreich resp. Vienna

10 Nov 2016 17:54

Developer for Austria and Svalbard
Creator of the Radiator Springs mod for ATS
Mods by ETS2-User: Facebook page

Image

User avatar
paulo4
Posts: 45
Joined: 04 Apr 2016 17:02
Location: France

11 Nov 2016 10:13

Hello, thank you for message

Hello your page is very interesting but there is not what I'm looking for: what I'm looking for is how to modify the version of a mod eg a truck.
Thank you very much.
Last edited by tkk7406 on 11 Nov 2016 14:38, edited 1 time in total.
Reason: Please don't double post; use the "Edit" button instead
Image

User avatar
LoaderSaints
Moderator
Posts: 1752
Joined: 31 Mar 2014 13:49
Location: LoaderTech HQ, Uusimaa, Finland
Contact:

12 Nov 2016 08:01

You just need to edit the Manifest files if you want to change the compatible versions:
http://modding.scssoft.com/wiki/Documen ... od_manager
ImageImage
ImageImage
ImageImage

User avatar
paulo4
Posts: 45
Joined: 04 Apr 2016 17:02
Location: France

12 Nov 2016 22:02

LoaderSaints wrote:You just need to edit the Manifest files if you want to change the compatible versions:
http://modding.scssoft.com/wiki/Documen ... od_manager


Is it possible that you do it yourself because I did not succeed from my mod?
Image

User avatar
LoaderSaints
Moderator
Posts: 1752
Joined: 31 Mar 2014 13:49
Location: LoaderTech HQ, Uusimaa, Finland
Contact:

13 Nov 2016 17:33

All you need to do is to add the following line into the manifest file:

Code: Select all

compatible_versions[]: "1.25.*"
(that will make the mod compatible with ETS2 1.25 but it does not mean the mod will actually work in that version of the game)
ImageImage
ImageImage
ImageImage

User avatar
paulo4
Posts: 45
Joined: 04 Apr 2016 17:02
Location: France

13 Nov 2016 18:58

Hi,
How do I do it when there is no manifest file? Thank you in advance. =)
Image

User avatar
Vøytek
Developer
Posts: 9844
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

13 Nov 2016 19:31

If there's no manifest file, then there's no problem because mod can't be displayed as incompatible so it loads on every version...
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

User avatar
paulo4
Posts: 45
Joined: 04 Apr 2016 17:02
Location: France

13 Nov 2016 19:53

Zniwek wrote:If there's no manifest file, then there's no problem because mod can't be displayed as incompatible so it loads on every version...


It may be the physics file which is incompatible because I have downloaded a mod in version 1.16, there is no manifest file and is incompatible with version 1.25. I do not know why.
Image

User avatar
LoaderSaints
Moderator
Posts: 1752
Joined: 31 Mar 2014 13:49
Location: LoaderTech HQ, Uusimaa, Finland
Contact:

14 Nov 2016 07:56

Technically speaking the mod isn't incompatible but outdated. I suggest looking at the game.log's output and looking for [ERROR] tags when trying to use the mod in-game. Once you find some errors in the game.log you can see which file is at fault and then you should edit that file or add it into the mod if it is missing (mostly the case with MAT files).
ImageImage
ImageImage
ImageImage



Post Reply
  • Information