Custom signs not working?

For problems that are not caused by ProMods
Post Reply
Posts: 12
Joined: 16 Sep 2018 20:30
Location: Los Angeles, California

30 Jul 2019 03:56

Hello, I will try to keep this brief. I am currently working on a 1:3 scale map of California in the game, and I am currently working on I-405, I-105, and CA-91. I decided to start with the city of Torrance, within LA county. I made custom signs in /material/sign/atlas/*.mat, but they just don't appear in the map editor.

Contents of /material/sign/atlas/:
Screenshot_3.png (86.58 KiB) Viewed 461 times
The contents of, ca_91.tobj, and ca_91.mat are:
ca_91.jpg (7.68 KiB) Viewed 461 times
The .tobj file leads to /material/sign/atlas/

Contents of .mat file:

Code: Select all

material : "ui"
	texture : "ca_91.tobj"
	texture_name : "texture"
Screenshot of Content Browser, "Sign Image"

What am I doing wrong? Why don't my other highway images show up? Any help will be very much appreciated.
Screenshot_4.png (240.3 KiB) Viewed 461 times
Author of 1:3-scale California [WIP], help would be appreciated

Posts: 50
Joined: 09 Nov 2013 11:46

30 Jul 2019 18:01

In your mod folder for signs, you have to tell the game to look for your atlas - def/sign/atlas/ca_91.sii for example. Look at original files for more info.

Posts: 12
Joined: 16 Sep 2018 20:30
Location: Los Angeles, California

31 Jul 2019 04:12

Thank you so much for trying to help me, but my whole mod is now completely broken, and I can't fix it.

When I started this thread, I was about to go to sleep. The next morning, I made all the .sii files I needed, and used the original game ones as my point of reference. Here is one of them:

Code: Select all

image_atlas :
  atlas_name: "ca_57"
  material_path: "/material/sign/atlas/ca_57.mat"
  # names
  images_names: 1
  images_names[0]: "ca 57"
  # left right bottom top
  images_coords: 1
  images_coords[0]: (0, 128, 128, 0)
These all look the same, but with other highway names and numbers. I placed these into my def.scs files in store compression, and started up the game. When I opened my map, I was received by this:
Screenshot_5.png (90.81 KiB) Viewed 374 times
Whenever I close one, another one opens with the same message, but with a different number. I tried removing the new files from my def.scs file, and I completely removed the folder /def/sign/ from the mod, but that still has no effect.
Despite removing the new files and updating my mod base.scs (I updated /base/map/), it still gives me the same message. It is incredibly frustrating that I can't get my mod to work, especially since I've been working on it for four months now. Any help would be appreciated, as I don't want to lose 4 months of work.

Not even my backup from 2 days ago works, the mod (or at least the def.scs file) seems completely broken, and I haven't been able to get it to work. As you can imagine, this is incredibly frustrating.
Author of 1:3-scale California [WIP], help would be appreciated

User avatar
Posts: 9664
Joined: 05 Jan 2014 19:38
Location: Luboń

31 Jul 2019 15:17

This error isn't caused by definitions, but by map sectors.

You probably forgot to get one of edited sector's file(s) from base/map/usa to yourmod.scs/map/usa and now you have an inconsistency. Using a previously working .scs file should be fine.
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]:

Posts: 12
Joined: 16 Sep 2018 20:30
Location: Los Angeles, California

02 Aug 2019 05:38

Thank you for trying to help me, but it works only partially. I went into game\American Truck Simulator\Base\Map\Autosave, and the autosave file worked. When I saved it however, placing the mod.scs file into my mod from the game directory still gave me the same error above, and even the autosave is broken. Apparently, the game seems to either be corrupting the files, or it is screwing them up in some way or another. I really don't want to lose 4 months of progress, I have no clue why saving the map will make it stop working.

When I save it, there are no errors; the errors are when I try to load the modded base.scs with the updated map.mbd and the map files. Even the autosave seems to be corrupted, or at least it doesn't work, and I have no clue why the game is doing that. Any help would be greatly appreciated, and I'll add you to the credits.

Edit: nevermind, I tried using an old version of my mod from two months ago, and it works. Although I lost some progress, at least I have my mod back. I believe there was something wrong with the base.scs file itself, so I re-installed the game itself, and also downgraded my mod to an older version that doesn't give me any errors. Thank you, Vøytek!
Author of 1:3-scale California [WIP], help would be appreciated

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest