ETS2 Issues

For problems that are not caused by ProMods
Post Reply
ShadowTrucking
Posts: 2
Joined: 04 Aug 2019 13:30

04 Aug 2019 13:32

So, just recently I have been playing quite a bit of ETS2. I have it installed through Steam, yet I use, NVIDIA GeForce Now, to play it through. Which so far has been going fine.

However, I also have all the DLC Expansions, which have been working perfectly, until the start of last week, the week before everything was working perfectly. Fast forward, to last Monday, and ETS2 started to act strange.

I have and all I use, is the base level, vanilla game, yes I have a couple of Mods, for graphical improvements, all of which are fine and up to date. However, when I tried to load a game, it stated that "Beyond the Baltic Sea" was missing. Which it is not, I have and already purchased it, and own it as well. Under DLC, it is ticked, and shows that it was purchased on the (14/4/2019).

I have un-clicked it, then re-installed it, and verified the game files, yet nothing. So why is it not working?!

I have also un-installed then re-installed ETS 2, and the "Beyond the Baltic DLC", to which nothing occurs, so where as I have been able to explore, previously the Baltic states, Finland, Russia etc. I can not explore them, as apparently I need the "Beyond the Baltic Sea" which I already own, and shows up as being part of the Installed DLC.

Aaaaaaaaggghhhhhhh!!!!

Any help?



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests