Invalid Client. Even if I have the last ETS2 1.35 version and TruckersMPlauncher.

Post here if you are having problems with ProMods in Multiplayer
Locked
Ticreut29
Posts: 22
Joined: 27 May 2019 08:00

20 Oct 2019 08:53

Hi, I'm trying to join the Promods Server when I clicked on the button drive I have this error
20191020093513_1.jpg
20191020093513_1.jpg (112.1 KiB) Viewed 448 times
One strange thing, the last supported version of ETS2 for the TruckersMP launcher is 1.35.3.4s but I'm on 1.35.3.20s so if anyone can help me.

PS: -I will post on this forum and TruckersMP Forum.
-I buy Euro truck simulator 2 on steam and I have all 5 DLC.
-I post this issue on TruckersMP, useful if you can't help me here.
-I try to Reinstall the client but it's don't fix the issue.

Sorry for my bad English.
Maps mods
Ets2: Maps combo From Wombat
ATS: Canadream + Mexico maps + Sierra Nevada + Coast to Coast + Minor Urban Overhaul + Mega Resource

User avatar
ShawnCZek
TruckersMP
Posts: 24
Joined: 12 Aug 2019 09:56
Contact:

20 Oct 2019 09:27

Hello Ticreut29,

It seems like you are using a modified version of ProMods. If you have just downloaded ProMods v2.42, make sure that the addons, which you are using, are up-to-date, too.
TruckersMP client and servers allow you to use only the newest version of ProMods' content.

Kind regards.

Ticreut29
Posts: 22
Joined: 27 May 2019 08:00

20 Oct 2019 09:53

Now it's work. Simply I just redownload middle east addons and it fixes the problem.
Problem solved!
Maps mods
Ets2: Maps combo From Wombat
ATS: Canadream + Mexico maps + Sierra Nevada + Coast to Coast + Minor Urban Overhaul + Mega Resource



Locked
  • Information
  • Who is online

    Users browsing this forum: No registered users and 4 guests