ProMods v2.01 and patch 1.23?

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
User avatar
Nissantruck
Posts: 913
Joined: 02 Sep 2013 16:13
Location: Vantaa Finland

10 Apr 2016 16:30

clarion99 wrote:
mattem wrote:1. You can disable auto-update on steam, e.g. wait until ProMods update.
You can not disable auto updates anymore. Steam will force you to update.
That is true and i hate that,because when SCS gives a new game update then i cant use my ETS2 until Promods map is compatible,because they will not usually work together at the same time.So then i need to wait for the Promods update with out driving my ETS2 truck,but i can drive my ATS truck,when i wait for the next Promods update to come. :(
Image

Image

I did use Ets1,Ukts and Gts.But now i use Ets2 and Ats.I also relocate cars for Nissan and Volvo,but i also like my Ets2 Scania and i also like my Ats Volvo VNL 780 too.
Senior Beta-Tester and translator for the Finnish language.

adgjl
Moderator
Posts: 1005
Joined: 05 Apr 2014 15:56
Donation rank:
Location: Sussex

10 Apr 2016 17:26

Once 1.23 has come out of beta you can to back to 1.22 (on Steam) by right clicking on ETS2 (in Grid View) > Properties > Betas tab > temporary_1_22 - 1.22.x for incompatible mods from the drop down list.
Last edited by adgjl on 10 Apr 2016 21:35, edited 1 time in total.
Reason: Removed false information. Listen to ETS2-User, not me!
Image

Bugs are love, bugs are life

User avatar
ETS2-User
Developer
Posts: 2934
Joined: 06 Aug 2014 22:34
Location: Oberösterreich

10 Apr 2016 19:27

That's not really true. The map format only changes when you save the map in the editor. The game itself can't change a mod. So downgrade to 1.22 and you'll be fine. :)
Developer for Austria and Svalbard
Creator of the Radiator Springs mod for ATS
Mods by ETS2-User: Facebook page

Image

Lamandus
Posts: 2
Joined: 22 Nov 2013 18:38

11 Apr 2016 17:32

you CAN on the other hand use the "temporary old versions" in the beta tab.

Pil0t Pedr0
Posts: 6
Joined: 10 Apr 2016 15:20
Donation rank:

11 Apr 2016 23:52

With Promods v2.01 installed in the game since yesterday and everything was working fine, But since ETS2 1.23 update today I am having the problem where the game loads okay, but as soon as I press anything the game crashes everytime. is there anyway that I can get back Promods v2.00 for the time being until Promods v2.02 comes out.

PS I have tried using the ETS2 temporary_1_22 - 1.22.x for incompatible mods. But it just totally disables both my profiles.

adgjl
Moderator
Posts: 1005
Joined: 05 Apr 2014 15:56
Donation rank:
Location: Sussex

12 Apr 2016 07:43

Try using the backup profile for the latest 1.22 version which ETS2 handily keeps- screenshot: http://promods.net/viewtopic.php?f=28&t ... 10#p117773
Image

Bugs are love, bugs are life

Pil0t Pedr0
Posts: 6
Joined: 10 Apr 2016 15:20
Donation rank:

12 Apr 2016 17:19

I have managed to sort it out, I took off Promods v2.01 and reinstated Promods v2.00 which I got off my son's game and it is working fine up to now. Think I will now wait for Promods v2.02 to be released. Thanks for the info

sylvantino
Posts: 8
Joined: 18 Nov 2015 19:47
Donation rank:

14 Apr 2016 03:18

mattem wrote:1. You can disable auto-update on steam, e.g. wait until ProMods update.

2. ProMods works fairly well with Beta 1.23, you will find much more problems with other mods, different traffic packs for instance, truckmods and so on.

I am not sure what is going on , but me and you are seeing two different behaviours with 2.01 on 1.23 patch for some reason.
I am not running any other mods while testing this map out on this latest patch. I get kick back to desktop from certain toll booths, and from a number of cities in the South of Europe. Romania is as bad it originally was for me.

Have no intention of going back to 1.22 unless I really have to. Pity they won't change the way this game looks, its needs a huge overhaul imo. and the fps issues are lengendary :/ Thats why I like promods, because even in scandinavia i do not get the fps all over the place like most other people do.

adgjl
Moderator
Posts: 1005
Joined: 05 Apr 2014 15:56
Donation rank:
Location: Sussex

14 Apr 2016 08:17

It is known that ProMods 2.01 + ETS2 1.23 leads to crashes at multiple locations. If you want a stable experience you really have to roll back to 1.22, and use the backup profile kept by the game.
Image

Bugs are love, bugs are life

User avatar
adrian007
Posts: 273
Joined: 12 Aug 2013 01:50
Donation rank:
Location: Brisbane Queensland

14 Apr 2016 08:31

What I do is quite simple I just go offline with Steam got caught out with this a few times now (am not really into achievements) this tends to work and also stops being bombarded by stuff I don't know ,want to know, or care about.
Adrian 8-)



Post Reply
  • Information