Updating Questions from a Long Break

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Post Reply
khaos526
Posts: 117
Joined: 19 Mar 2016 23:38

08 Jun 2019 00:20

Well it's not that I took a break from ETS2, it's just that I haven't updated anything at all for quite a long time due to things changing so fast, waiting for other mods to catch up and update and such (especially RusMaps) and so on.

Currently I am using the following Mods and Versions:
ETS2: 1.31.2.12s
ProMods: 2.40
RusMaps: 1.8.1 which seems it's no longer being updated
Southern Region: ??? Just states SRMap and no version #

JazzyCat AI Traffic: 8.3
JazzyCat Bus Traffic: 5.0

I was using Project Balkans but it was getting too much a year back waiting for mods to update with all the new ETS2 and Promod updates that I axed it for now.

Thinking of finally upgrading and have some questions first to make sure I have everything correct.

In my ProMods link (https://promods.net/viewtopic.php?f=5&t=3852) I don't see the new Baltic DLC being required. Is that still the case in that it's not necessary to purchase it? I have heard that it kind of messed things up anyways.

For RusMaps since there is no more updates since 1.8.1 (which I originally was waiting so long for) is the correct Fix I need the 1.5 (https://promods.net/viewtopic.php?f=42&t=25560)? Since I am using Promods and Southern Region?

Southern Region and Jazzy Cats I think should be straight forward to just download as I always have.

So does this seem correct in that I don't need the Baltic DLC and I have the correct Legacy Fix for RusMaps?

Thanks

User avatar
Vøytek
Developer
Posts: 9376
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

08 Jun 2019 00:25

Are you sure you're using 2.40?
2.40 requires ETS2 1.34 and Baltic DLC.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

User avatar
EdgeGladiator
Posts: 2377
Joined: 11 Mar 2017 11:54
Location: Argenteuil, Ile-de-France

08 Jun 2019 10:44

khaos526 wrote:
08 Jun 2019 00:20
In my ProMods link (https://promods.net/viewtopic.php?f=5&t=3852) I don't see the new Baltic DLC being required. Is that still the case in that it's not necessary to purchase it? I have heard that it kind of messed things up anyways.
It's because it's a old tutorial, from 2.30. Baltics DLC is require for the last update PM 2,40, but PM 2.33 didn't require Baltics DLC. After, do you play on ETS2 1.31 or ETS2 1.34 ? You need ProMods 2.30 for ETS2 1.31, not 2.40. All informations is indicated here : compat.php
khaos526 wrote:
08 Jun 2019 00:20
For RusMaps since there is no more updates since 1.8.1 (which I originally was waiting so long for) is the correct Fix I need the 1.5 (https://promods.net/viewtopic.php?f=42&t=25560)? Since I am using Promods and Southern Region?
So does this seem correct in that I don't need the Baltic DLC and I have the correct Legacy Fix for RusMaps?
It depend on what PM version do you use. Yeah you need this fix for ETS2 1.31 and PM 2.30. If you play with ETS2 1.34 and PM 2.33 (which don't require Baltics DLC), check this thread : https://promods.net/viewtopic.php?f=42&t=27138
Image

ProMods Junior Beta-Tester and Translator

[WIP] Southern France rework
[WIP] Mediterranean Map
[WIP] Maghreb Map
[REL] Real European Gas Stations Reloaded for Promods

[FR] Fiches conseille voyage : Route France, Espagne et Maroc on Yabiladi

khaos526
Posts: 117
Joined: 19 Mar 2016 23:38

08 Jun 2019 16:12

Vøytek wrote:
08 Jun 2019 00:25
Are you sure you're using 2.40?
2.40 requires ETS2 1.34 and Baltic DLC.
Sorry I'm using 230 and accidentally put in the version I need to get for ProMods which is 240, sorry about that.

EdgeGladiator wrote:
08 Jun 2019 10:44
It's because it's a old tutorial, from 2.30. Baltics DLC is require for the last update PM 2,40, but PM 2.33 didn't require Baltics DLC. After, do you play on ETS2 1.31 or ETS2 1.34 ? You need ProMods 2.30 for ETS2 1.31, not 2.40. All informations is indicated here : compat.php

It depend on what PM version do you use. Yeah you need this fix for ETS2 1.31 and PM 2.30. If you play with ETS2 1.34 and PM 2.33 (which don't require Baltics DLC), check this thread : https://promods.net/viewtopic.php?f=42&t=27138
Ok that 's what I thought and have the wrong outdated link I guess in my notes. I am attempting on updating everything soon (as long as there is no not another ProMod or ETS update in the next week or so). I don't play that often so I tend to just lag behind updates until big things have changed which iit has since the last update I did back in I think Aug of 2018. Trying to play catch up now before the Black Sea DLC comes out later this year...

Thanks everyone and will let you know if I have any weird issues...

User avatar
EdgeGladiator
Posts: 2377
Joined: 11 Mar 2017 11:54
Location: Argenteuil, Ile-de-France

08 Jun 2019 19:33

ok fine
Image

ProMods Junior Beta-Tester and Translator

[WIP] Southern France rework
[WIP] Mediterranean Map
[WIP] Maghreb Map
[REL] Real European Gas Stations Reloaded for Promods

[FR] Fiches conseille voyage : Route France, Espagne et Maroc on Yabiladi



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests