Mods showing incompatible [v2.33]

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Post Reply
KingCalifornia
Posts: 2
Joined: 03 Aug 2019 01:49

03 Aug 2019 12:54

Hi,

I wanted to try out this mod, and since i don't have the Baltic Sea DLC I downloaded the latest version not requiring it (v2.33). I then put it into the mod folder like the tutorial showed, but the mods show as incompatible on the mods manager.

I'm have the game on steam, the game version is 1.35.1.30s (so it should be up to date), and have checked the download files with the test tool for errors.

Image
Image

What can I do to make it work?

User avatar
Vøytek
Developer
Posts: 9365
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

03 Aug 2019 13:07

Check the Compatibility page carefully - PM 2.33 is for ETS2 1.34, not 1.35.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

KingCalifornia
Posts: 2
Joined: 03 Aug 2019 01:49

03 Aug 2019 13:22

So it isn't upward compatible then? Looks like i have to downgrade the version hten. Thanks for the help, i wouldn't have thought of that.

User avatar
Vøytek
Developer
Posts: 9365
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

03 Aug 2019 13:36

Yes, every ProMods version works only on the version it was released for. 2.33 won't work on 1.33 nor 1.35, only 1.34.
That's because in every game patch there are changes that require us to make a new, compatible, stable version.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 10 guests