Promods map don't work (aalborg, ferry)

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Post Reply
kac737
Posts: 1
Joined: 10 Nov 2014 13:45

09 Jul 2015 15:23

I have promods 1.95 but i can't create 1.95 def file
Game version: 1.18.1.3s

Here is a log:


I'am using fix for 1.7

User avatar
Jan Verschueren
Posts: 1860
Joined: 17 Aug 2013 21:11
Donation rank:
Location: Linkeroever, Antwerpen

09 Jul 2015 16:21

When using v1.95, you shouldn't use the v1.17 fix. Also note you shouldn't use v1.95 if you don't own the Scandinavia DLC (continue with v1.91, incl. v1.17 fix instead).
"You know you've played too much ETS2 when..." :lol: :P

"Bad cop" forum moderator, if required.

User avatar
MandelSoft
Lead Developer
Posts: 3771
Joined: 08 Aug 2013 10:48
Location: Zoetermeer [NL]

09 Jul 2015 16:21

You have multiple problems here:

Code: Select all

00:00:18.067 : Mounting extra package: C:/Users/Kacper/Documents/Euro Truck Simulator 2/mod/promods-def-v191.zip
00:00:18.113 : [zipfs] promods-def-v191.zip: read ok, 2623 entries [0xda84a83c]
00:00:18.113 : Mounting extra package: C:/Users/Kacper/Documents/Euro Truck Simulator 2/mod/promods-map-v195.scs
00:00:18.146 : [zipfs] promods-map-v195.scs: read ok, 1160 entries [0x9815bfec]
00:00:18.146 : Mounting extra package: C:/Users/Kacper/Documents/Euro Truck Simulator 2/mod/promods-v195.scs
00:00:18.870 : [zipfs] promods-v195.scs: read ok, 30549 entries [0x26e3ede6]
Generate a new DEF file. Your current DEF is for ProMods 1.91, but all other files you use are for 1.95. It's a standard procedure to generate a new def file for every new release.

Code: Select all

00:00:18.872 : Mounting extra package: C:/Users/Kacper/Documents/Euro Truck Simulator 2/mod/z_promods-v191-patch_compatibility_117.scs
00:00:18.901 : [zipfs] z_promods-v191-patch_compatibility_117.scs: read ok, 1529 entries [0x6516a9a]
Remove this file. This patch is only meant to make ProMods 1.91 compatible with ETS2 patch 1.17 and 1.18. ProMods 1.95 is fully compatible without the patch.

EDIT: Jan, this line indicates that he has the DLC installed:

Code: Select all

00:00:07.460 : [hashfs] dlc_north.scs: Mounted and validated, 7222 entries 
Your daily dose of wisdom!
╔═══╗────╔═╗╔═╗────╔╗
║╔═╗║────║║╚╝║║────║║
║╚═╝╠═╦══╣╔╗╔╗╠══╦═╝╠══╗
║╔══╣╔╣╔╗║║║║║║╔╗║╔╗║══╣
║║──║║║╚╝║║║║║║╚╝║╚╝╠══║
╚╝──╚╝╚══╩╝╚╝╚╩══╩══╩══╝
Don't ask us for a release date; we don't know either.

User avatar
ScaleStrait
Posts: 179
Joined: 30 Jun 2014 15:13
Location: Kaennuussa

09 Jul 2015 16:36

There is something wrong. I just tried to generate a def file for 1.95 but it just redirects to 1.91 def.

I think ScuL has to take a look that.
Satisfy hang up not residence permit your towel cloth over balcony!

adgjl
Moderator
Posts: 1005
Joined: 05 Apr 2014 15:56
Donation rank:
Location: Sussex

09 Jul 2015 17:39

The same is happening for me...
Image

Bugs are love, bugs are life

User avatar
ScuL
Founder
Posts: 8106
Joined: 31 Jul 2013 23:51
Location: Auckland, New Zealand

09 Jul 2015 23:17

1.95 file is back, it was accidentally replaced
I am Image Dutch living in Image New Zealand and I speak Image EN Image DE Image SE Image FR
Image

User avatar
Jan Verschueren
Posts: 1860
Joined: 17 Aug 2013 21:11
Donation rank:
Location: Linkeroever, Antwerpen

10 Jul 2015 00:46

MandelSoft wrote:<snip>
EDIT: Jan, this line indicates that he has the DLC installed:

Code: Select all

00:00:07.460 : [hashfs] dlc_north.scs: Mounted and validated, 7222 entries 
I missed the pastebin link. :oops:
"You know you've played too much ETS2 when..." :lol: :P

"Bad cop" forum moderator, if required.



Post Reply
  • Information
  • Who is online

    Users browsing this forum: aidnplays and 2 guests