My steering wheel doesnt work with ETS2

You can talk about anything here (but respect the rules)
Posts: 3
Joined: 07 Aug 2019 21:25

13 Aug 2019 21:17

So recently i picked up Logitech's Driving Force GT and i wanted to use it with ETS2. After sucessfull calibration, im pretty sure my computer in 100% registers my steering wheel. Now when i turn on ETS2 it seems like wheel is not turned on at all, i cant setup it up, it doesnt show up in drop down menu where i choose controls etc. I already looked up about it on internet but it didnt help. I cleaned up previous drivers that might been instaled previously, i installed 5.10 64x version of Logitech profiler, i restared computer numerous times, tried to plug in wheel to different USB ports and nothing works. Also metion, i tried it with different game but practically same developers (Scania Truck Driving Simulator) and my driving wheel automatically worked with it, so i dunno why ETS2 cant work with it. Please help me !

Dodano po 55 minutach 52 sekundach:
Ok nevermind, i found the solution completly randomly. So i went to Big Picture, to the controler options and there is that option to force steam input setting, i had it on but i turned it off and ETS2 automaticaly registers my wheel, yeah so admin you can close this topic :)

  • Information
  • Who is online

    Users browsing this forum: No registered users and 5 guests