Promos 2.30

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Post Reply
Prince17
Posts: 4
Joined: 05 Aug 2018 11:53

02 Sep 2018 11:46

Hi All,
I just downloaded promos 2.27 for 1.31. Now I come to know new version 2.30 is released. Is it possible if I can directly use 2.30 for my 1.31 virsion. :roll:

User avatar
Volleybal4life
Moderator
Posts: 6800
Joined: 01 Jun 2014 15:49
Donation rank:
Location: Gouda, South Holland, The Netherlands
Contact:

02 Sep 2018 11:47

Yes, you certainly can.

Just disable and delete all 2.27 files, and enable all 2.30 files.
Spamming the forum since June 2014



Image
Some say, I'm addicted to ETS2. But then I say. No, it's ProMods, it's a way of life.
No. 3 forum spammer!

You want a game map?
You get a game map! (ETS2 (WIP))
You get a game map! (ATS (WIP))

Prince17
Posts: 4
Joined: 05 Aug 2018 11:53

03 Sep 2018 01:31

Thanks a lot I will do it right away

Prince17
Posts: 4
Joined: 05 Aug 2018 11:53

03 Sep 2018 15:22

Hi I saw message where it is mentioned that I need to have " the Vive la France, Italia and other mods as well. Do I need to have those mods before I start updating from 2.11 to 2.30.

Recently I have updated 1.25 to 1.31 and now I want to update promod from 2.11 to 2.30. please advice how I should start updating my game.


xela1961
Posts: 209
Joined: 22 Feb 2016 00:55

04 Sep 2018 11:58

You must have the original game, and after installing it, you must buy all DLC (North&East, France, Italy) and to have them installed into the game updated. After that you can download ProMods (the new v.31, or other versions) with all files, unzip them somewhere in computer and after that move them on MOD folder, start the game and activate in right side, (be carreful to have activated the files for only one version (to not have files with v.31 and v30 also !!!)... and also to have them in the order as request.
In the same way (after cheqing, and if the game work) you can use RusMap files, South Region... and others. (load them, unzip, move, activate )
Important is the respect the loading order. It very important to be OK for all the files.

Prince17
Posts: 4
Joined: 05 Aug 2018 11:53

08 Sep 2018 05:30

I download mod 2.30 and follow the procedure. Then I copy all the files in to mod folder. Then I remove the old version 2.11 from mod manager. Then I start the game but at the time of loading it goes 50-60% then suddenly I got out from the game.

Where I can download DLC (North&East, France, Italy) may be I need to have those again.

Do you think I need to completely remove the 1.25 version and install again 1.31.

User avatar
ScuL
Founder
Posts: 7865
Joined: 31 Jul 2013 23:51
Location: Auckland, New Zealand

08 Sep 2018 06:30

You should definitely ensure that your game is running 1.31.
But nobody can say anything for certain unless you include a game.log
I am Image Dutch living in Image New Zealand and I speak Image EN Image DE Image SE Image FR
Image

User avatar
samuray
Posts: 213
Joined: 08 Oct 2013 19:42
Donation rank:
Location: Talsi, Latvia
Contact:

08 Sep 2018 14:03

Prince17 wrote:
08 Sep 2018 05:30
I download mod 2.30 and follow the procedure. Then I copy all the files in to mod folder. Then I remove the old version 2.11 from mod manager. Then I start the game but at the time of loading it goes 50-60% then suddenly I got out from the game.

Where I can download DLC (North&East, France, Italy) may be I need to have those again.

Do you think I need to completely remove the 1.25 version and install again 1.31.
You can buy all the DLCs on Steam. And just let the Steam update the game up to 1.31

racdavies
Posts: 34
Joined: 04 Dec 2016 20:26
Donation rank:

13 Sep 2018 10:36

Prince17 wrote:
08 Sep 2018 05:30
I download mod 2.30 and follow the procedure. Then I copy all the files in to mod folder. Then I remove the old version 2.11 from mod manager. Then I start the game but at the time of loading it goes 50-60% then suddenly I got out from the game.

Where I can download DLC (North&East, France, Italy) may be I need to have those again.

Do you think I need to completely remove the 1.25 version and install again 1.31.
If you already had them you dont need to buy them again.... providing you paid for them.



Post Reply
  • Information