Modding Q&A

Modding school: Learn it from the masters
User avatar
Vøytek
Developer
Posts: 9484
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

31 Jan 2019 15:39

Did you edit this roundabout in Blender?
It's looking for "lane 2" - but in this case you only have "lane 0".
Image
I created a small layout to help you understand:
Image
Lane "value" grows with every lane you move away from the central node.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

JoeP82
Posts: 20
Joined: 14 Sep 2017 10:44

01 Feb 2019 15:44

Nope didn't edit in blender have very little knowledge on use of blender :P

The roundabout is a prefab I found within the content browser was suitable for what I wanted, that's the original prefab shown within the library.
Only installed content are SCS and Promods, so would assume it's part of Promods library content it's called "uk r1 x r1 sw round narrow tmpl"

User avatar
Vøytek
Developer
Posts: 9484
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

01 Feb 2019 15:53

Ah, it may be a prefab from MandelSoft's new set of UK prefabs.
You should use "uk road 1 tmpl" with this roundabout, then textures match nicely ;)

I'll let him know about this bug.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

User avatar
Msg97
Posts: 43
Joined: 28 Dec 2016 17:04
Location: Morocco

07 Feb 2019 09:33

Does anyone know how to add African map background to map editor ?

fisherm
Posts: 15
Joined: 07 Aug 2018 14:52
Donation rank:

08 Feb 2019 16:59

How do I change the place where you start when testing a map?

Some of the guides say you press "S" and it lets you move the car icon, but it doesn't seem to work for me so maybe it's out of date.

Thanks!

edit

Another question - I can't get companies to function and create jobs when I test my custom map - logos don't appear etc.. Here's what I did - can anyone point out what's missing?

1) In the project def folder, created a company.MyProject.sii with the standard companies e.g. @include "company/bhv.sii"
2) in the project def/company folder, created sii text files for the companies (examples copied from the base extraction)
3) in the project def/company folder, created folders for each company (e.g. a bhv folder), with contents copied from the base extraction
4) in the bhv/editor folder, created a MyCity.sii containing the line SiiNunit{ company_def : .MyCity {city: MyCity prefab: dlc_fr_14}} where the prefab id comes from the content browser
5) Deleted surplus content (e.g. editor folder files referencing cities that aren't currently on the map)

Is this all that's needed? The older guides talk about editing the initial saves folder, but that seems out of date.
The promods guide mentions copying materials folders, but that seems to be only required for custom named companies.
Some of the guides also say the company prefab needs to be at the same height as the city zone, but that might also be out of date.

Thanks so much. I've been stalled with this for several weeks.
Last edited by Trucker2223 on 09 Feb 2019 19:09, edited 1 time in total.
Reason: merged double post, please use Edit button instead of double posting

User avatar
scan720
Posts: 1241
Joined: 31 May 2014 13:57
Donation rank:
Location: Munich, Germany
Contact:

10 Feb 2019 14:04

Hi Guys,
I have an Question to the Map Editor.
And the Question is: Why is my work not saving?
I have the Skill for the Editor, but the thing is that every Time when I am saving my Work, its not there next time in loading.
And thats the Problem, I have the Time for mapping. But this Thing damage this Project.

Knows an Developer any solution?

Best Regards,
scan720

Heres an Example of Gamelog:
Last edited by scan720 on 10 Feb 2019 14:31, edited 1 time in total.
PM User since: 1.62
Currently: Busy with school (Slow Progress)

User avatar
Vøytek
Developer
Posts: 9484
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

10 Feb 2019 14:29

fisherm wrote:
08 Feb 2019 16:59
Another question - I can't get companies to function and create jobs when I test my custom map - logos don't appear etc.. Here's what I did - can anyone point out what's missing?

1) In the project def folder, created a company.MyProject.sii with the standard companies e.g. @include "company/bhv.sii"
2) in the project def/company folder, created sii text files for the companies (examples copied from the base extraction)
3) in the project def/company folder, created folders for each company (e.g. a bhv folder), with contents copied from the base extraction
4) in the bhv/editor folder, created a MyCity.sii containing the line SiiNunit{ company_def : .MyCity {city: MyCity prefab: dlc_fr_14}} where the prefab id comes from the content browser
5) Deleted surplus content (e.g. editor folder files referencing cities that aren't currently on the map)
It's better to use lower-case names (myproject instead of MyProject) and use something more unique, for example your nick ;)

I don't think you need step #1 and #2.
Investigate your game.log file, it probably shows errors.
scan720 wrote:
10 Feb 2019 14:04
I have the Skill for the Editor, but the thing is that every Time when I am saving my Work, its not there next time in loading.
Are you packing your edited sectors and loading them as a mod? I don't see anything like that in your log.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

User avatar
scan720
Posts: 1241
Joined: 31 May 2014 13:57
Donation rank:
Location: Munich, Germany
Contact:

10 Feb 2019 14:41

"Are you packing your edited sectors and loading them as a mod? I don't see anything like that in your log."
No, I mean how can I load it in the Editor, to continue my work.
PM User since: 1.62
Currently: Busy with school (Slow Progress)

User avatar
Vøytek
Developer
Posts: 9484
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

10 Feb 2019 14:45

That's exactly what I said.
Please, read/watch a tutorial first, because I think you're missing the basics, which were explained many times already.
Image
Currently working on: various stuff
#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: http://youtube.pl/vooytek

User avatar
scan720
Posts: 1241
Joined: 31 May 2014 13:57
Donation rank:
Location: Munich, Germany
Contact:

10 Feb 2019 14:56

OK, This iks Epic.
I watched now a Very good Videos and get it now.
Thanks @Voytek
Btw. I will work now on the S3 in Poland
PM User since: 1.62
Currently: Busy with school (Slow Progress)



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests