ProMods 2.46 for game version 1.37 has been released. Please be kind to the download servers :)
Please note that TruckersMP (multi-player) is still on game version 1.36 / ProMods 2.45

Inkompatibel

German
User avatar
Trucker2223
Moderator
Posts: 5412
Joined: 16 Apr 2017 13:17
Donation rank:

04 Jan 2020 16:34

Dafür brauchst du unteranderem das Cabin Accesories DLC.
No. 4 forum spammer

No Support via PM!!

ProMods Senior Beta Tester since 2.30
ProMods Moderator since 1. January 2019



Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests