what dlc do you need

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Post Reply
yolo6090
Posts: 1
Joined: 23 Oct 2017 10:42

13 May 2018 14:28

i want to get promods but i do not know what dlc

User avatar
Volleybal4life
Moderator
Posts: 5923
Joined: 01 Jun 2014 15:49
Donation rank:
Location: Gouda, South Holland, The Netherlands

13 May 2018 15:33

You will need all map-DLC, Going East, Scandinavia and Vive la France.

In the future you will need Italia too.

And in the more distant future, you will need those map-DLC too.

More information can be found here: compat.php
Spamming the forum since June 2014



Image
Some say, I'm addicted to ETS2. But then I say. No, it's ProMods, it's a way of life.
No. 3 forum spammer!

You want a game map?
You get a game map! (ETS2 (WIP))
You get a game map! (ATS (WIP))

Sylar7653
Posts: 3
Joined: 17 May 2018 22:48

18 May 2018 00:06

Hi! I heard about this mod just yesterday, did some research and watched youtube videos.. I must say.. WOW.. just WOW guys..
I have a question though. Currently I own this contect: ES2, High Power Cargo Pack, Special Transport, Heavy Cargo Pack, Going East, Scandinavia. I didin't want to buy France, nor Italy but then I won't be able to use this mod? Just theoretically.. I could revert my game on steam to 1.25.x and install the promod version of v2.11 and then if I never let steam to update my game (if thats even possible) then I would be able to use promod and don't have France nor Italy.. Is that about right?
Thanks in advance for your answer!

User avatar
CptCaribbean
Posts: 467
Joined: 24 Jul 2016 16:32
Location: Barcelona, Tabarnia
Contact:

18 May 2018 01:46

Yup, but you miss some cool content.
Image

Junior Beta-Tester since 2.26

Sylar7653
Posts: 3
Joined: 17 May 2018 22:48

18 May 2018 10:41

Yeah, I understand. And that content is just huge... and Vive La France is on sale atm.. damn I'm just going to buy it and problem is solved.. ;)

User avatar
Vøytek
Developer
Posts: 7966
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

18 May 2018 10:42

That's a very good decision and you won't regret it ;)
Image
Current development work: traffic signs

#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: https://youtube.pl/vooytek

User avatar
Trucker2223
Posts: 1408
Joined: 16 Apr 2017 13:17
Donation rank:

18 May 2018 11:31

Buit you should also Keep and mind that future 2.30 and Releases after that Need Italy to. So you should consider buying that to, so you don't get any Problems in the future.
No Support via PM!!

ProMods Junior Beta Tester since 2.26

Sylar7653
Posts: 3
Joined: 17 May 2018 22:48

18 May 2018 13:45

The very next version of the mod, which will be compatible with ES2 1.31.x will already require Italy? I'd like to wait with buying Italy when its on 50% sale.

User avatar
CptCaribbean
Posts: 467
Joined: 24 Jul 2016 16:32
Location: Barcelona, Tabarnia
Contact:

18 May 2018 13:50

After 2.30 Italia DLC will also be a requirement and very surely after 2.40 (still very far away) BBS will be another requirement.
Image

Junior Beta-Tester since 2.26

User avatar
Vøytek
Developer
Posts: 7966
Joined: 05 Jan 2014 19:38
Location: Luboń
Contact:

18 May 2018 14:01

Sylar7653 wrote:
18 May 2018 13:45
The very next version of the mod, which will be compatible with ES2 1.31.x will already require Italy?
2.27 won't require Italy (it'll be released as soon as possible for 1.31)
2.30 will require Italy (it'll be released later)
Image
Current development work: traffic signs

#1 forum spammer
Enjoying PM since 1.52
YouTube channel [PL]: https://youtube.pl/vooytek



Post Reply
  • Information
  • Who is online

    Users browsing this forum: calania and 3 guests